L2j T2.3 (gracia final) error.

Find the proper support area, Saga-Version.
Forum rules
READ NOW: L2j Forums Rules of Conduct
Post Reply
Posts: 2
Joined: Tue Jul 08, 2014 10:55 pm

L2j T2.3 (gracia final) error.

Post by wakawaka2345 » Tue Jul 08, 2014 11:45 pm

Right to the point.. i'm trying to make a l2j server for me and my friend to play..
The problem is that i can't seem to make it work and i've got the nagging feeling it has something to do with java, and frankly i've run out of options on what to do. Searched google countless times.. nothing.
so here I am looking for some help on this forum :).
detailed info:
The log "java0.log.0"

Code: Select all

2014.07.08 16:14:54,814 WARNING 1   net.sf.l2j.gameserver.scripting.L2ScriptEngineManager   Failed executing script: D:\L2 server\test grac\l2j-server\gameserver\data\scripts\ai\group_template\Monastery.java. See Monastery.java.error.log for details.2014.07.08 16:14:55,705 WARNING 1   net.sf.l2j.gameserver.scripting.L2ScriptEngineManager   Failed executing script: D:\L2 server\test grac\l2j-server\gameserver\data\scripts\ai\individual\Orfen.java. See Orfen.java.error.log for details.2014.07.08 16:14:56,112 WARNING 1   net.sf.l2j.gameserver.scripting.L2ScriptEngineManager   Failed executing script: D:\L2 server\test grac\l2j-server\gameserver\data\scripts\handlers\MasterHandler.java. See MasterHandler.java.error.log for details.2014.07.08 16:14:59,837 WARNING 1   net.sf.l2j.gameserver.scripting.L2ScriptEngineManager   Failed executing script: D:\L2 server\test grac\l2j-server\gameserver\data\scripts\quests\SagasScripts\SagasSuperClass.java. See SagasSuperClass.java.error.log for details.
which is pretty much the only errors it shows up, although i can swear that there were more errors than that.

the script logs, on the other hand, all show this :

Code: Select all

Error on: *\gameserver\data\scripts\quests\SagasScripts\SagasSuperClass.java.error.logLine: -1 - Column: -1 compilation failed

I've tried to create many servers - freya, gracia, high five. all the same.

For the strange part i CAN connect to the server with the client (even my friend did, which is hilarious because usually i had more problems making him join than setting the server up), however admincommands - do not work. gracia and freya - can't target mobs/npc, use inventory items (except gear, you can equip it), you can run around (atleast :lol:). on high five though i could target and attack mobs, also use items, but the gm commands were utterly broken.
When I tried to use the admin commands it usually said that the command doesn't exist, and something about handlers in the console.

Here's an image from the console : Image

Please give me some suggestions on this. And i'm terribly sorry if this is a dumb mistake (me is being me :lol: ).

Posts: 2
Joined: Tue Jul 08, 2014 10:55 pm

Re: L2j T2.3 (gracia final) error.

Post by wakawaka2345 » Wed Jul 09, 2014 8:33 pm


Solution : it appears that (as always) i was an idiot and didn't read info. the T2.3 doesn't support java 8.
downgraded to java 6.
(note that uninstalling higher versions helps if you failed to run it even if java 6 is present).

Posts: 1
Joined: Mon Nov 17, 2014 11:57 am

Re: L2j T2.3 (gracia final) error.

Post by zafar500 » Mon Nov 17, 2014 12:01 pm

Thanks for sharing. good luck

Post Reply