We moved our repositories to BitBucket!

If you can't login or you can't register to the forums do not rise an issue, instead please write to support (at) l2jserver.com

Check our wiki!

Report server issues here

Forum has been updated to phpBB 3.2, let's see if this fixes some minor bugs we had.

Thank you for visiting http://www.l2jserver.com/

[Test] Need a report about it

If something doesn't fit in any other forum then post it here.
Forum rules
READ NOW: L2j Forums Rules of Conduct
Post Reply
Mage
Posts: 277
Joined: Fri Apr 17, 2009 2:29 pm

[Test] Need a report about it

Post by Mage » Mon Feb 10, 2014 11:50 am

Hello guys, i need a fast test. Revision ~last one

- Spawn 200 monster.
- Use command //kill 2000

Tell me if you got lag, i mean when all the mobs are dying (spamming server packets), if your next action (for example a movetolocation) got delay or not.

Thank you
Forum rules: Please do not use or alter the official L2J Avatars/Signatures/Names for your personal use.

User avatar
BiggBoss
L2j Veteran
L2j Veteran
Posts: 1104
Joined: Wed Apr 15, 2009 3:11 pm
Location: Spain

Re: [Test] Need a report about it

Post by BiggBoss » Mon Feb 10, 2014 11:58 am

that depends on many factors:
- machine
- jvm thread schedule (since all are the same priority, you wont know at all)

btw, if you got move delay, it will be mostly graphic lag, server side you will be proably moved in time or with milliseconds delay
Image

Mage
Posts: 277
Joined: Fri Apr 17, 2009 2:29 pm

Re: [Test] Need a report about it

Post by Mage » Mon Feb 10, 2014 12:03 pm

BiggBoss wrote:that depends on many factors:
- machine
- jvm thread schedule (since all are the same priority, you wont know at all)

btw, if you got move delay, it will be mostly graphic lag, server side you will be proably moved in time or with milliseconds delay
I'm in localhost, and i got a very powerfull machine.

When i kill all mobs with the command i got 4-5 seconds delay cause on client i see all gurds dieing.

I'm trying debugging the problem cause i got massive lag during mass pvp. And i noticed also during siege with lot of guards. (also if there are low players during pvp, like 20)

PS: i'm not using last version of l2j, this is why i'm telling to do the test.

Thank you
Forum rules: Please do not use or alter the official L2J Avatars/Signatures/Names for your personal use.

User avatar
BiggBoss
L2j Veteran
L2j Veteran
Posts: 1104
Joined: Wed Apr 15, 2009 3:11 pm
Location: Spain

Re: [Test] Need a report about it

Post by BiggBoss » Mon Feb 10, 2014 12:07 pm

as i said, its probably graphic lag, the render engine get a peak while rendering all dying animations, and wont be able to render you walking or doing any other action while all mobs are dying.

Before your server downgrade its performance by packet broadcasting, your client will be exhausted by graphic renderization
Image

Mage
Posts: 277
Joined: Fri Apr 17, 2009 2:29 pm

Re: [Test] Need a report about it

Post by Mage » Mon Feb 10, 2014 12:13 pm

BiggBoss wrote:as i said, its probably graphic lag, the render engine get a peak while rendering all dying animations, and wont be able to render you walking or doing any other action while all mobs are dying.

Before your server downgrade its performance by packet broadcasting, your client will be exhausted by graphic renderization
I was debugging with some logs the packet Client->Server and seems u are correct. Infact also during my lag if i eas clicking to move, the server was reciving that packet. (and after the lag my char moved)

So we can exclude that the lag from killing/dieing mobs is the same with mass pvp from char.
Forum rules: Please do not use or alter the official L2J Avatars/Signatures/Names for your personal use.

Cresceus
Posts: 238
Joined: Tue Jan 15, 2008 8:20 am
Location: Germany

Re: [Test] Need a report about it

Post by Cresceus » Mon Feb 10, 2014 12:17 pm

Take a look here viewtopic.php?f=81&t=28330.

The little fix by JOJO worked for me.


So if you haven't fixed it yet, perhaps this will work for you, too.

But this fix has nothing to do with PvP.
Last edited by Cresceus on Mon Feb 10, 2014 12:34 pm, edited 1 time in total.

vampir
Posts: 113
Joined: Sun Mar 28, 2010 6:17 pm

Re: [Test] Need a report about it

Post by vampir » Mon Feb 10, 2014 12:27 pm

In mass pvp, same thing is happening. There are a lot of actions(animations, skills, new characters coming) that game client have to show on the screen. You could make button for every player, which would stop less important actions from being sent to client.

angkor_tm
Posts: 135
Joined: Fri Nov 19, 2010 1:38 pm

Re: [Test] Need a report about it

Post by angkor_tm » Mon Feb 10, 2014 12:28 pm

test for you....
3 sec delay dont move...
client (for graphic delay test)
core i7
8gb ddr3 1600
nvidia GeForce GTX 650

Mage
Posts: 277
Joined: Fri Apr 17, 2009 2:29 pm

Re: [Test] Need a report about it

Post by Mage » Mon Feb 10, 2014 12:33 pm

vampir wrote:In mass pvp, same thing is happening. There are a lot of actions(animations, skills, new characters coming) that game client have to show on the screen. You could make button for every player, which would stop less important actions from being sent to client.
Exactly. I don't say an important thing. The lagg is only ZONE LAG, i mean people lag only where there is the mass pvp, not on all server.
Forum rules: Please do not use or alter the official L2J Avatars/Signatures/Names for your personal use.

Mage
Posts: 277
Joined: Fri Apr 17, 2009 2:29 pm

Re: [Test] Need a report about it

Post by Mage » Mon Feb 10, 2014 12:37 pm

angkor_tm wrote:test for you....
3 sec delay dont move...
client (for graphic delay test)
core i7
8gb ddr3 1600
nvidia GeForce GTX 650
Thank you for test.
Forum rules: Please do not use or alter the official L2J Avatars/Signatures/Names for your personal use.

angkor_tm
Posts: 135
Joined: Fri Nov 19, 2010 1:38 pm

Re: [Test] Need a report about it

Post by angkor_tm » Mon Feb 10, 2014 12:39 pm

Lag only if you are near this area, if you far from area no lag.
Tested from 2 clients at the same time

Mage
Posts: 277
Joined: Fri Apr 17, 2009 2:29 pm

Re: [Test] Need a report about it

Post by Mage » Mon Feb 10, 2014 1:53 pm

angkor_tm wrote:Lag only if you are near this area, if you far from area no lag.
Tested from 2 clients at the same time
Me too, that's a problem during mass pvp cause there is always ZONE lag when there are lot of players online.
Forum rules: Please do not use or alter the official L2J Avatars/Signatures/Names for your personal use.

User avatar
Zoey76
L2j Inner Circle
L2j Inner Circle
Posts: 6954
Joined: Tue Aug 11, 2009 3:36 am

Re: [Test] Need a report about it

Post by Zoey76 » Mon Feb 10, 2014 9:15 pm

I don't see any lag, except that takes about half a second for all the drops and herbs to appear.
Using Eclipse 4.15 - OpenJDK11 - MariaDB 10.4.12 - L2J Server 2.6.2.0

angkor_tm
Posts: 135
Joined: Fri Nov 19, 2010 1:38 pm

Re: [Test] Need a report about it

Post by angkor_tm » Tue Feb 11, 2014 7:33 am

Disabled herbs and drops all and lag is present...

amouage1
Posts: 1
Joined: Sun May 17, 2020 3:34 pm

Re: [Test] Need a report about it

Post by amouage1 » Mon May 18, 2020 2:59 pm

Maybe someone have fix this mass pvp/ action area lagg ?

Post Reply