We moved our repositories to BitBucket!

If you can't login or you can't register to the forums do not rise an issue, instead please write to support (at) l2jserver.com

Check our wiki!

Report server issues here

Forum has been updated to phpBB 3.2, let's see if this fixes some minor bugs we had.

Thank you for visiting http://www.l2jserver.com/

Skill: Spoil, Sound upon "..condition .. activated.." does not play

Support for the latest build of L2J Server, get help here with installations, upgrades, problems.
Do not post bugs reports here, use viewforum.php?f=77 instead.
There is no support for other server builds than the official provided by l2jserver.com
Forum rules
READ NOW: L2j Forums Rules of Conduct
Post Reply
User avatar
zachramuz
Posts: 15
Joined: Fri Dec 13, 2019 7:47 am
Location: /home/zachramuz

Skill: Spoil, Sound upon "..condition .. activated.." does not play

Post by zachramuz » Thu Jul 30, 2020 1:57 pm

So I've said something about this on discord. But I think this is more appropriate place to record this.
During my Lineage2 playtime which has to be about 2000 hours if not more, I played dwarfs quite a lot and I mainly played low-mid rates, while my highest rates was x75. So I did quite some spoiling.

Some people might not notice this. But when you use spoil it's not 100% chance. So in current L2 Classic and in chronicles c2-c6 it used to be a sound that plays upon successful "spoil condition activated" message it's similar sound to that when you get a quest item.

Now I played for a few hours on vanilla L2JServer and it took me some time to actually get a failed spoil, but I noticed that in System Messsage.

So here roughly how it looks like upon successful spoil
Image

You can see a sentence "The spoil condition has been activated"

And here you can see how system log looks like upon failed spoil (it really took me few hours to get one failed spoil)
Image


Anyway, this is hardly readable text when you're killing monsters one after another, and this indicating sound is the only thing most spoilers are waiting for to stop using spoil and just finish the mob.
The sound does not play for me, it's very similar to one you get after aquiring a quest item.
The sound of the skill itself, some fireworky fiery sound is one thing, but after that there, has to be indication of whether spoil was successful, otherwise there would have to be colored system message whether it was success or not.

That is even more true for artisants/warsmiths, who has spoil lvl 1 and are actually able to get ssd and similar level recipes after tens or even hundreds of applications of spoil upon a mob, which would be entire nightmare without that sound indication.

I mean the only thing I came to L2JServer to attempt to aid in developement is because of nostalgia and because I need some project for my recently started Computer Science studies, however much I hate java, I still have feelings for lineage2, but I only care about low-mid rate issues, such as this one and not so much about any custom fancy stuff.

P.S. I can't post on bug report so I'm posting here again.
Keep it Simple Stupid
Image

Post Reply