We moved our repositories to BitBucket!

If you can't login or you can't register to the forums do not rise an issue, instead please write to support (at) l2jserver.com

Check our wiki!

Report server issues here

Forum has been updated to phpBB 3.2, let's see if this fixes some minor bugs we had.

Thank you for visiting http://www.l2jserver.com/

Custom multisell problem

Support for the latest build of L2J Server, get help here with installations, upgrades, problems.
Do not post bugs reports here, use viewforum.php?f=77 instead.
There is no support for other server builds than the official provided by l2jserver.com
Forum rules
READ NOW: L2j Forums Rules of Conduct
Post Reply
krepstas
Posts: 57
Joined: Mon Sep 17, 2012 10:14 am

Custom multisell problem

Post by krepstas » Sun Oct 27, 2013 2:11 pm

If you want to receive support we need this info to help you properly.
» Find Revision
L2J Revision Number:6245
L2JDP Revision Number:9982
Hi,

Im having problem to make custom multisell for gmshop.
I added custom npc with id 10003. With instance of L2Merchant.
My html main page looks like :

Code: Select all

<html><head><body scroll="GmShop"><table border=0 cellpadding=0 cellspacing=0 width=292 height=358 background="Asuki_GMshop.tlo"><tr><td valign="top" align="center">     <table border=0 cellpadding=0 cellspacing=0>        <tr><td width=256 height=145 background="Asuki_GMshop.tarcza"></td></tr>    </table>    <table border=0 cellpadding=0 cellspacing=0>            <tr><td align=center><img src="L2UI.SquareGray" width=150 height=1></td></tr>            <tr><td height=14></td></tr>    </table>     <table border=0 cellpadding=0 cellspacing=1 bgcolor=8B8386>        <tr>        <td></td>        <td align=center><button action="bypass -h npc_%objectId%_multisell 10086" value="Armors" width=116 height=26 back="L2UI_ct1.button_df" fore="L2UI_ct1.button_df"></tr>        <td></td>        </tr>    </table>        <table border=0 cellpadding=0 cellspacing=1 bgcolor=8B8386>        <tr>            <td></td>            <td align=center><button value="Weapons" action="bypass -h npc_%objectId%_multisell 10087" width=116 height=26 back="L2UI_ct1.button_df" fore="L2UI_ct1.button_df"></td>            <td align=center><button value="Jewels" action="bypass -h npc_%objectId%_multisell 10088" width=116 height=26 back="L2UI_ct1.button_df" fore="L2UI_ct1.button_df"></td>        <td></td>        </tr>    </table>     <table border=0 cellpadding=0 cellspacing=1 bgcolor=8B8386>        <tr>            <td></td>            <td align=center><button value="Clan Skills" action="bypass -h npc_%objectId%_multisell 10041" width=116 height=26 back="L2UI_ct1.button_df" fore="L2UI_ct1.button_df"></td>            <td align=center><button value="Consumables" action="bypass -h npc_%objectId%_Chat 4" width=116 height=26 back="L2UI_ct1.button_df" fore="L2UI_ct1.button_df"></td>        <td></td>        </tr>    </table>    <table border=0 cellpadding=0 cellspacing=0>            <tr><td align=center><img src="L2UI.SquareGray" width=205 height=1></td></tr>            <tr><td height=14></td></tr>    </table>     <table border=0 cellpadding=0 cellspacing=1 bgcolor=8B8386>        <tr>            <td></td>            <td align=center><button value="Vote Reward" action="bypass -h npc_%objectId%_Chat 1" width=116 height=26 back="L2UI_CT1.OlympiadWnd_DF_Reward_Down" fore="L2UI_CT1.OlympiadWnd_DF_Reward"></td>            <td align=center><button value="Donate" action="bypass -h npc_%objectId%_Chat 2" width=116 height=26 back="L2UI_CT1.OlympiadWnd_DF_HeroConfirm_Down" fore="L2UI_CT1.OlympiadWnd_DF_HeroConfirm"></td>        <td></td>        </tr>    </table>    <table border=0 cellpadding=0 cellspacing=0>            <tr><td align=center><img src="L2UI.SquareGray" width=150 height=1></td></tr>            <tr><td height=14></td></tr>    </table></td></tr></table></body></html>
For example im trying to open this multisell : <button action="bypass -h npc_%objectId%_multisell 10086" value="Armors" width=116 height=26 back="L2UI_ct1.button_df" fore="L2UI_ct1.button_df"></tr>
This multisell looks like this :

Code: Select all

<?xml version="1.0" encoding="UTF-8"?><list xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../xsd/multisell.xsd"><npcs><npc>10003</npc></npcs><!-- D-Grade Armors --> <list> <!-- Brigandine Heavy Armor --><item id="1"><ingredient id="57" count="1000000"/><production id="352" count="1"/><production id="2378" count="1"/><production id="2411" count="1"/><production id="2425" count="1"/><production id="2449" count="1"/><production id="2493" count="1"/></item>
Then mutlisell loads i get error :

Code: Select all

MultisellData: Could not parse 10013.xml file: cvc-maxInclusive-valid: Value '131313' is not facet-valid with respect to maxInclusive '65535' for type '#AnonType_npcnpcslist'.MultisellData: Could not parse 10014.xml file: cvc-elt.1: Cannot find the declaration of element 'list'.MultisellData: Could not parse 10015.xml file: cvc-elt.1: Cannot find the declaration of element 'list'.MultisellData: Could not parse 10020.xml file: cvc-elt.1: Cannot find the declaration of element 'list'.MultisellData: Could not parse 10023.xml file: cvc-elt.1: Cannot find the declaration of element 'list'.MultisellData: Could not parse 10041.xml file: cvc-elt.1: Cannot find the declaration of element 'list'.MultisellData: Could not parse 10042.xml file: cvc-elt.1: Cannot find the declaration of element 'list'.MultisellData: Could not parse 10050.xml file: cvc-elt.1: Cannot find the declaration of element 'list'.MultisellData: Could not parse 10051.xml file: cvc-elt.1: Cannot find the declaration of element 'list'.MultisellData: Could not parse 10053.xml file: cvc-elt.1: Cannot find the declaration of element 'list'.MultisellData: Could not parse 10056.xml file: cvc-elt.1: Cannot find the declaration of element 'list'.MultisellData: Could not parse 10059.xml file: cvc-elt.1: Cannot find the declaration of element 'list'.MultisellData: Could not parse 10084.xml file: cvc-elt.1: Cannot find the declaration of element 'list'.MultisellData: Could not parse 10086.xml file: schema_reference.4: Failed to read schema document '../xsd/multisell.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not<xsd:schema>.MultisellData: Could not parse 10087.xml file: cvc-elt.1: Cannot find the declaration of element 'list'.MultisellData: Could not parse 10088.xml file: cvc-elt.1: Cannot find the declaration of element 'list'.MultisellData: Could not parse 10096.xml file: cvc-elt.1: Cannot find the declaration of element 'list'.MultisellData: Could not parse 10097.xml file: cvc-elt.1: Cannot find the declaration of element 'list'.MultisellData: Could not parse 10098.xml file: cvc-elt.1: Cannot find the declaration of element 'list'.MultisellData: Could not parse 10100.xml file: schema_reference.4: Failed to read schema document 'multisell.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.MultisellData: Could not parse 10101.xml file: schema_reference.4: Failed to read schema document 'multisell.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.MultisellData: Loaded 189 multisell lists.Cache[HTML]: Running lazy cache
And then i try to open that multisell it says :
MultisellData: can't find list id: 10013 requested by player: Krepst, npcId:10003

How to solve this problem..? I even tried those default multisell ,but still same.
P.S. Yes i already turned on custom multisell in general.prop

Thanks for answers in advice. :arrow:

EDIT : I think problem is here : MultisellData: Could not parse 10086.xml file: schema_reference.4: Failed to rea
d schema document '../xsd/multisell.xsd', because 1) could not find the document
; 2) the document could not be read; 3) the root element of the document is not
<xsd:schema>. But who causes this problem.. ?1) I checked xsd/ folder multisell.xsd is there.. 2) How the hell it cannot be readed if another multisell uses it ? 3) ??
Last edited by krepstas on Sun Oct 27, 2013 2:17 pm, edited 1 time in total.

User avatar
jurchiks
Posts: 6762
Joined: Sat Sep 19, 2009 4:16 pm
Location: Eastern Europe

Re: Custom multisell problem

Post by jurchiks » Sun Oct 27, 2013 2:15 pm

For starters, you have 2 opening list tags in that XML.
If you have problems, FIRST TRY SOLVING THEM YOURSELF, and if you get errors, TRY TO ANALYZE THEM, and ONLY if you can't help it, THEN ask here.
Otherwise you will never learn anything if all you do is copy-paste!
Discussion breeds innovation.

krepstas
Posts: 57
Joined: Mon Sep 17, 2012 10:14 am

Re: Custom multisell problem

Post by krepstas » Sun Oct 27, 2013 2:19 pm

jurchiks wrote:For starters, you have 2 opening list tags in that XML.
oh sorry. Missclicked here maybe

Code: Select all

<?xml version="1.0" encoding="UTF-8"?><list xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../xsd/multisell.xsd"><npcs><npc>10003</npc></npcs><!-- D-Grade Armors -->  <!-- Brigandine Heavy Armor --><item id="1"><ingredient id="57" count="1000000"/><production id="352" count="1"/><production id="2378" count="1"/><production id="2411" count="1"/><production id="2425" count="1"/><production id="2449" count="1"/><production id="2493" count="1"/></item></list>
still nothing.

User avatar
jurchiks
Posts: 6762
Joined: Sat Sep 19, 2009 4:16 pm
Location: Eastern Europe

Re: Custom multisell problem

Post by jurchiks » Sun Oct 27, 2013 2:22 pm

The "Failed to read schema document '../xsd/multisell.xsd'" can happen if your multisell is in a subfolder of data/multisell. You need to adjust the relative path to the XSD file.
If you have problems, FIRST TRY SOLVING THEM YOURSELF, and if you get errors, TRY TO ANALYZE THEM, and ONLY if you can't help it, THEN ask here.
Otherwise you will never learn anything if all you do is copy-paste!
Discussion breeds innovation.

krepstas
Posts: 57
Joined: Mon Sep 17, 2012 10:14 am

Re: Custom multisell problem

Post by krepstas » Sun Oct 27, 2013 2:25 pm

jurchiks wrote:The "Failed to read schema document '../xsd/multisell.xsd'" can happen if your multisell is in a subfolder of data/multisell. You need to adjust the relative path to the XSD file.
EDIT: SOLVED.
BTW: i got inspired by your signature ,hahaha and fixed it. As it says : Before asking look good your problem..
Last edited by krepstas on Sun Oct 27, 2013 2:32 pm, edited 1 time in total.

User avatar
jurchiks
Posts: 6762
Joined: Sat Sep 19, 2009 4:16 pm
Location: Eastern Europe

Re: Custom multisell problem

Post by jurchiks » Sun Oct 27, 2013 2:32 pm

Not xsd, xml. Where is your xml?
Edit: ok, nvm.
Any other problems?
Last edited by jurchiks on Sun Oct 27, 2013 2:33 pm, edited 1 time in total.
If you have problems, FIRST TRY SOLVING THEM YOURSELF, and if you get errors, TRY TO ANALYZE THEM, and ONLY if you can't help it, THEN ask here.
Otherwise you will never learn anything if all you do is copy-paste!
Discussion breeds innovation.

krepstas
Posts: 57
Joined: Mon Sep 17, 2012 10:14 am

Re: Custom multisell problem

Post by krepstas » Sun Oct 27, 2013 2:33 pm

jurchiks wrote:Not xsd, xml. Where is your xml?
Thanks anyway

arianvangjeli
Posts: 11
Joined: Fri Apr 25, 2014 3:05 pm

Re: Custom multisell problem

Post by arianvangjeli » Sun May 04, 2014 10:12 pm

i have the same problem with you , i have tryied everying , but still nothing. any one can help?

agtohack
Posts: 3
Joined: Sat Oct 10, 2015 2:02 am

Re: Custom multisell problem

Post by agtohack » Tue Oct 13, 2015 4:26 am

I have the same problem, but no one say how to fix it :( Can anybody help me please?

Post Reply