We moved our repositories to BitBucket!

If you can't login or you can't register to the forums do not rise an issue, instead please write to support (at) l2jserver.com

Check our wiki!

Report server issues here

Forum has been updated to phpBB 3.2, let's see if this fixes some minor bugs we had.

Thank you for visiting http://www.l2jserver.com/

country limitation

Support for the latest build of L2J Server, get help here with installations, upgrades, problems.
Do not post bugs reports here, use viewforum.php?f=77 instead.
There is no support for other server builds than the official provided by l2jserver.com
Forum rules
READ NOW: L2j Forums Rules of Conduct
Post Reply
darknessneo
Posts: 196
Joined: Mon Apr 26, 2010 11:00 pm

country limitation

Post by darknessneo » Tue Jan 29, 2019 7:54 pm

Hello,
login version = 4900:5137M
datapack version = 8305:8632M

i wan to know if we can limit the server acces to a specific country, cuz im bored to block russian ip who wan to hack my telnet server ^^'
so i wan to limit to only french ppl where my server is.
ty ^^

User avatar
regenx
Posts: 302
Joined: Sat Jul 17, 2010 6:55 am

Re: country limitation

Post by regenx » Wed Jan 30, 2019 7:10 am

1. Use a website login/register function.
2. Use a .htaccess and ban all russian IP addresses or entire country.
3. Use SSH, give remote access ONLY to your IP address (from your Linux firewall)
4. Disable TelNet.

:+1:

User avatar
u3games
Advanced User
Advanced User
Posts: 1154
Joined: Sun Feb 27, 2011 7:00 pm
Location: España
Contact:

Re: country limitation

Post by u3games » Wed Feb 06, 2019 8:48 pm

darknessneo wrote:
Tue Jan 29, 2019 7:54 pm
Hello,
login version = 4900:5137M
datapack version = 8305:8632M

i wan to know if we can limit the server acces to a specific country, cuz im bored to block russian ip who wan to hack my telnet server ^^'
so i wan to limit to only french ppl where my server is.
ty ^^
With L2JMods is posible ;)
Image

User avatar
Sacrifice
Advanced User
Advanced User
Posts: 1018
Joined: Thu Aug 14, 2014 6:31 am
Location: Spain

Re: country limitation

Post by Sacrifice » Tue Feb 12, 2019 3:40 pm

Yes! :+1:
Retail GameMaster and Developer using Eclipse for Java Developers (64 bits), OpenJDK11 (64 bits), MySQL 8.0+ (64 bits).

Post Reply