We have recently updated our forum software.

If you can't login or you can't register, write Zoey76 a direct message at (require GitHub account).

Users with multiple accounts has been merged: app.php/rules#multi-account

When new forum styles are ready they will be released.

Thank you for visiting http://www.l2jserver.com/

https://github.com/L2J/L2J_Server/wiki/Setup-Eclipse

Cant Login to GameServer

Support for the latest build of L2J Server, get help here with installations, upgrades, problems.
Do not post bugs reports here, use viewforum.php?f=77 instead.
There is no support for other server builds than the official provided by l2jserver.com
Forum rules
READ NOW: L2j Forums Rules of Conduct
PacWhite
Posts: 20
Joined: Sat Sep 22, 2012 10:56 pm

Cant Login to GameServer

Postby PacWhite » Tue Dec 31, 2013 6:20 pm

If you want to receive support we need this info to help you properly.
L2J Revision 6291M:
L2JDP Revision 9641:

Hello Guys,
its a long time ago of my last post. But now i have a problem that f**kz my Brain.
I set up a new L2 Server for a Test of some scripts.... normally thats basic.. and makes no probs..
but not today...

(My Playboard is a Virtual Machine with connecting to my host Network - Windows 7 Server 2012)
I have Adminrights and all other stuff ;D


I install Eclipse and the other stuff to compile a new Core from SVN.
Compile ... bla bla bla all Succes
I have extract the Zips in one Folder of D:\whatthefuckfolder\
I had registere a Game Server (Server ID 4 Lionna --- i guess)
I change the IP in ipconfig.xml to my DHCP given IP = 192.168.2.101

So i start my Login / Game Server. All Fine, no errors and fails.
-> FireWall is OFF(Always..the sh.t of Micrsoft is ... you know what i mean)...
-> The FireWall of the Client PC is naturlamente OFF!
= All PORTS OPEN. ( Ithink that was only 2106 & 7777 TCP) but wayne..
Now i modify my Client (yes i know the Forum here dont like the edits on Clients - but i dont like the edits on my hosts^^ =) & i think 90% of the Forumuser have modifed they client.. x'D)


Now to the problems.

I start my client, with autocreat i make a new account, i log in.. now i see the lists of Server.. i click on the server ... AND NOTHING >.< i can fu** the button Confirm but nothing go...
Server is Online and shows "Light"...

What i have do to solve the Problem:
Google.. its my friend...
I check my Configs.. all by hand-.-
i check the ipconfig.xml.
i check if my client the right (probaly yes? if not the right client it dont log me in or?! but i can login to my Serverlist..)
I make a new Compile of the Core ... not solve..
And Google, yeah my Friend.. but 60% is crap on the inet..
So short: I can login but not into the GameServer.

Some Configs..

<?xml version="1.0" encoding="UTF-8"?>
<!-- Note: If file is named "ipconfig.xml" this data will be used as network configuration, otherwise server will configure it automatically! -->
<!-- Externalhost here (Internet IP) or Localhost IP for local test -->
<gameserver address="192.168.2.101" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../data/xsd/ipconfig.xsd">
<!-- Localhost here -->
<define subnet="127.0.0.0/8" address="127.0.0.1" />
<!-- Internalhosts here (LANs IPs) -->
<define subnet="10.0.0.0/8" address="10.0.0.0" />
<define subnet="172.16.0.0/19" address="172.16.0.0" />
<define subnet="192.168.0.0/16" address="192.168.0.0" />
</gameserver>


if something need SAY iT xD ...

Thanks Guys, and HAPPY NEW YEAR :) if i forgot to say :X

Edit: what i forgott -> Ill dont become any errors in the Console while clicking on Confirm and other stuff... its look all normaly

Edit²: Ok i found my Problem. it was a fail in my ipconfig.xml

<?xml version="1.0" encoding="UTF-8"?>
<!-- Note: If file is named "ipconfig.xml" this data will be used as network configuration, otherwise server will configure it automatically! -->
<!-- Externalhost here (Internet IP) or Localhost IP for local test -->
<gameserver address="192.168.2.101" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../data/xsd/ipconfig.xsd">
<!-- Localhost here -->
<define subnet="127.0.0.0/8" address="127.0.0.1" />
<!-- Internalhosts here (LANs IPs) -->
<define subnet="10.0.0.0/8" address="10.0.0.0" />
<define subnet="172.16.0.0/19" address="172.16.0.0" />
<define subnet="192.168.0.0/16" address="192.168.0.0" /> //This must be change in 192.168.2.101
</gameserver>

Return to “High Five Support”

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest