We moved our repositories to BitBucket!

If you can't login or you can't register to the forums do not rise an issue, instead please write to support (at) l2jserver.com

Check our wiki!

Report server issues here

Forum has been updated to phpBB 3.2, let's see if this fixes some minor bugs we had.

Thank you for visiting http://www.l2jserver.com/

End of Jython support

Read me first before posting anywhere!
Forum rules
READ NOW: L2j Forums Rules of Conduct
Post Reply
User avatar
Zoey76
L2j Inner Circle
L2j Inner Circle
Posts: 6846
Joined: Tue Aug 11, 2009 3:36 am

End of Jython support

Post by Zoey76 » Thu May 25, 2017 5:01 pm

Hello everyone,

We started porting every script from Jython to Java, then we made a decision to rewrite every quest and script from Jython to Java, and we have been doing that for the last 3 to 5 years, along with this we started by rejecting Jython contributions, then we limited support for official and custom scripts, finally we locked down the script support for Jython all together.

We are now 1 quest away from having all in Java, I'm currently developing quest 335 (long quest!) and after I complete it, we will release 2.6.1.0 some time next month.

After that we will refactor Core and eventually Datapack to remove unnecessary code and libraries used only for Jython support, after that more changes to the script system will be done, such as unification of Listeners system, separation of quests and AIs by implementing better abstraction, better support for instances and events, plugins support, etc.

My recommendation to you is that you start porting your Jython scripts now and get rid of them by the end of the next (June) month.

L2J developers will not provide official support for Jython anymore, so it's up to the community to help each other and share knowledge and scripts.

Finally we are evaluating adding some custom features to the source, probably HorridoJoho's scheme buffer with some changes, that will give users an officially maintained NPC buffer.
Using Eclipse Neon 4.6.3 - JDK8u112 - MySQL 5.7.17 - L2J Server :+1:
Live support

User avatar
Gladicek
Posts: 625
Joined: Wed Jan 19, 2011 6:25 pm
Location: Czech Republic

Re: End of Jython support

Post by Gladicek » Fri May 26, 2017 5:32 pm

RIP cancer Jython :kappa:
ImageImage
L2J retired

g4rwin
Posts: 1
Joined: Thu Jun 15, 2017 3:02 am
Location: United Kingdom

Re: End of Jython support

Post by g4rwin » Thu Jun 15, 2017 3:11 am

R.I.P

User avatar
KGB1st
Posts: 198
Joined: Sat Jul 26, 2014 5:58 pm
Location: ИРК, РФ, СИБИРЬ!
Contact:

Re: End of Jython support

Post by KGB1st » Wed Aug 02, 2017 8:27 pm

TypeError: int() argument must be a string or a number
[02/08 20:58:29] /home/l2jserver/game/data/scripts/quests/999_T1Tutorial/__init__.py
Traceback (innermost last): File "quests/999_T1Tutorial/__init__.py", line 236, in onKill
TypeError: int() argument must be a string or a number
# Made by Mr. Have fun! - version 0.4 by Rolarga
# C5 addons by DrLecter
# C4 addons by Kerberos
# updated to Kamael by Kerberos

Code: Select all

Ex = int(qs.get("Ex"))
not understand what is this qs.get("Ex")

User avatar
u3games
Advanced User
Advanced User
Posts: 1135
Joined: Sun Feb 27, 2011 7:00 pm
Location: España
Contact:

Re: End of Jython support

Post by u3games » Thu Sep 21, 2017 9:14 pm

Why ...

Code: Select all

compile 'org.python:jython:2.2.1'
in build.gradle ??
Image

User avatar
Zoey76
L2j Inner Circle
L2j Inner Circle
Posts: 6846
Joined: Tue Aug 11, 2009 3:36 am

Re: End of Jython support

Post by Zoey76 » Fri Oct 06, 2017 4:52 am

u3games wrote:
Thu Sep 21, 2017 9:14 pm
Why ...

Code: Select all

compile 'org.python:jython:2.2.1'
in build.gradle ??
Because we will remove core support and libraries on the next big release.
Using Eclipse Neon 4.6.3 - JDK8u112 - MySQL 5.7.17 - L2J Server :+1:
Live support

User avatar
u3games
Advanced User
Advanced User
Posts: 1135
Joined: Sun Feb 27, 2011 7:00 pm
Location: España
Contact:

Re: End of Jython support

Post by u3games » Sat Oct 07, 2017 10:34 am

Zoey76 wrote:
Fri Oct 06, 2017 4:52 am
u3games wrote:
Thu Sep 21, 2017 9:14 pm
Why ...

Code: Select all

compile 'org.python:jython:2.2.1'
in build.gradle ??
Because we will remove core support and libraries on the next big release.
Ok perfet ^^
Image

Post Reply